Gentoo CFLAGS einstellen

Unter /etc/make.conf stellt man die CFLAGS für ein Gentoo-System ein.
Diese Informationen braucht es, damit der Compiler weiss, auf welchem System er kompilieren muss.
Ab GCC-Version 4.2  sucht dieser automatisch die besten Einstellungen, wenn man als Option native angibt.

CFLAGS="-march=native -02 -pipe"

Install Postgrey on Gentoo

Der Begriff Graue Liste bzw. Greylisting (brit.)/Graylisting (USA) bezeichnet eine Form der Spam-Bekämpfung bei E-Mails, bei dem die erste E-Mail von unbekannten Absendern temporär abgewiesen und erst nach einem zweiten Zustellversuch angenommen wird. Sehr effektiv gegen Spam-Mails, weil diese kein zweites mal von der gleichen Adresse Spams versenden

Installation

emerge -av mail-filter/postgrey

Einstellungen

Die Einstellungen befinden sich unter /etc/conf.d/postgrey.

POSTGREY_TYPE=“inet“
POSTGREY_HOST=“127.0.0.1″
POSTGREY_PORT=“10030″
POSTGREY_SOCKET=“/var/spool/postfix/private/postgrey“
POSTGREY_PID=“/var/run/postgrey.pid“
POSTGREY_DELAY=100
POSTGREY_TEXT=“Greylisted for %s seconds“
POSTGREY_OPTS=“–inet=127.0.0.1:60000″

Wirklich interessant ist die Einstellung POSTGREY_DELAY, hier gibt man an, wie lange(in Sekunden) dauert es, bis er das Mail wieder entgegen nimmt.

Whitelist

Es gibt ein paar schlecht konfigurierte Mailclients, die kein 2tes Mal versuchen das Mail zu senden. Für das gibt es die postgrey_whitelist_clients.local unter /etc/postfix/. Dort fügt man alle Mail-Server ein die keinen 2ten Versuch starten.

Beispiel für Sunrise

 # sunrise.ch (does not resend email)
 /^.*-proxy-.*\.sunrise\.ch$/

fglrx auf meinem Dell Studio XPS 16

So nach langem Basteln und diversen gescheiterten Versuchen, konnte ich den fglrx-Treiber von ATI auf meinem Gentoo zum laufen bringen. Das Hauptproblem lag wahrscheinlich darin, dass ich den radeaonHD-Treiber auch noch installiert habe und diese sich zusammen nicht so gut verstehen.

Also habe ich mal nachgeschaut welche Treiber alles schon installiert sind:

qlist -I x11-drivers

Dann sollte man eine Liste erhalten, meine sieht jetzt so aus:

  • x11-drivers/ati-drivers
  • x11-drivers/xf86-input-evdev
  • x11-drivers/xf86-input-synaptics

Also habe ich dann den radeaonHD-Treiber deinstalliert, in meiner ‚make.conf‘ den VIDEO_CARDS auf fglrx umgestellt. Danach habe ich diese Packete installiert:

  • emerge -av x11-base/xorg-server
  • emerge -av x11-base/xorg-drivers
  • emerge -av ati-drivers

Danach habe ich mein xorg.conf gelöscht, bzw unbenannt. Und das von ATI mitgelieferte Programm ausgeführt.

aticonfig –initial

Das hatte mir dann ein neues ‚xorg.conf‘ erstellt.

Und siehe da, jetzt funktioniert es!!

eix und das Dollerzeichen

Habe gerade herausgefunden, durch zufall, dass man mit eix viel genauer suchen kann, wenn man an das Ende ein Doller hängt. SOmit werden nur Einträge gesuht die mit diesem Suchwort aufhören und nicht irgendwo dazwischen stehen

Beispiel:

eix gnome -> liefert 114 Treffer
eix gnome$ -> liefert nur 11 Treffer

Somit hat man den besseren ¨Uberblick.